Migrating / moving site definition templates from 2010 to 2013

These are the steps to fix the site definition error :

Category : MissingSiteDefinition
Error : True
UpgradeBlocking : False

Message : 1 Sites in database [CDB_Technology13] have reference(s) to a missing site definition, Id = [75804], Lcid = [1033], compatibility level = [14].
Remedy : The site definition with Id 75804 is referenced in the database [CDB_Technology13], but is not installed on the current farm for
sites with compatibility level 14. The missing site definition may cause upgradeto fail. Please install any solution which contains the site definition and restart upgrade if necessary.

Using the code in this article :http://sharepointsharks.blog/missingsitedefin…tabase-migration/   , ! run this on the source SharePoint server, in my case SharePoint 2010. this code will list all available site templated used on the farm their code, and al list of all the sites using site templates with their id. in this example the 75804  was referencing the IT#0 template.

Copy from the Source SharePoint 2010 to the target SharePoint 2013 :

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\1033\XML

the xml file format will be webtemp[template name].xml for example WEBTEMPIT.xml for the IT  site template.

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\SiteTemplates
copy the whole folder, for example if the template name is  IT#0  then copy the folder IT from the source 2010 to the same path on the 2013 farm.

after moving the file restart the SharePoint 2013 servers and run the test-spcontentdatabase, your errors should be resolved.

Leave a Reply

Your email address will not be published. Required fields are marked *